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Requirements 
WinTEC v4 requires a few things to run properly on your computer. 
 
Windows 98 or later, Windows XP is recommended 
1024x768 resolution or better 
Serial port 
 
Most laptops made in the last 5 years meet the resolution requirement.  If you do not meet this 
requirement, the software will still run, but will not fit on the screen.  Additionally, if you are using a 
large font to make your display easier to read; things may appear strange or misaligned.  It is strongly 
recommended that you use the normal font size with WinTEC. 
 
If you don’t have a serial port on your computer, PCMCIA adapters are available from a number of 
places online.  USB adapters are also widely available and tend to cost considerably less, but some work 
well and others do not work at all.  We have found that the Sabrent part# SBT-USC1M, works well. 
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Using WinTEC v4 
WinTEC v4 is designed to be easy to navigate and use for most people without reading the manual.  But 
there are always useful pointers in the manual and if you have read this far, you are a rare breed and I 
commend your effort to educate yourself. 

Installing the software 
To install WinTEC, simply insert the CD into your 
CD ROM drive, open the drive in Windows Explorer 
and double click “Setup.exe”.  Desktop CDROM 
drives will have a ridge in the tray for the small CD.  
You will actually see two files called “setup”, look 
for the file with “.exe” on the end, .  The file you 
want is highlighted in Figure 1. 
 
Once setup begins follow the on screen instructions.  
You may change the installation directory if 

necessary, but the default directory is 
recommended. 

Configuring the software 
Selecting your Serial Port 
Chances are, before you will be able to communicate wit
change the communications port WinTEC is using.  You
clicking on “Tools->Options->Control Panel” (Figure 2)
the configuration screen (Figure 3). 

 

Figure 2: Bringing up the Control Panel 

When you have a serial port on your computer, this is usu
port is often 3 or 4.  If you are using a USB adapter, the p
computer.  To find out what port number your COM port
click on “My Computer”, click properties (Figure 4), sele
Manager”.  You will see a tree that lists all the hardware 
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Figure 1: The Setup file for installation 
h your Electromotive system, you will need to 
 can change the port in the Control Panel by 
 and then clicking on the communications tab in 

Figure 3: Communications Tab 
 

ally 1.  If you have a PCMCIA adapter, the 
ort number is different on almost every 
 is, plug in your COM adapter if needed.  Right 
ct the Hardware tab and then click “Device 
in your computer.  Near the bottom there is a 
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Figure 5: COM ports listed in 
Device Manager 

Figure 4: Right-click ‘My Computer’ and then select 
Properties 

group called ‘Ports (COM & LPT)’ (Figure 5).  Double click on that item and you will see your port(s) 
listed along with the port number.  Note the number there (i.e. COM7) and close the device manager.  
Then go into WinTEC and select the port using the directions above. 
  
Changing the Dashboard appearance 
The appearance of the dashboard can be configured in the Control Panel by clicking on the Monitor tab 
(Figure 6).  The Day and Night mode radio buttons select the background for the dashboard.  Day mode 
(Figure 7) has a white background and defaults to black numbers and needles.  Night mode (Figure 8) 
has a black background and defaults to red needles and green numbers. 
 
Both day and night modes have 
default colors for the numbers and 
gauge needles, but both can be 
changed.  By clicking the Choose 
button next to the item you would 
like to change, you will be shown a 
color palette to select a color. 
 
By default, the cell in each table 
currently being used by the unit is 
highlighted in yellow.  Checking the 
option “Overlay AFR colors in 
Tables” makes the box highlight 
match the color of the AFR needle 
by default.  This option has no effect 
on the XDI2.  This option is 
described in more detail in the 
section on using the tables. 

Figure 6: Monitor Options Screen 
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Figure 7: Dashboard Day Mode 

Figure 8: Dashboard Night Mode 

 
User Interface options 
When checked, the “Dock 2D Graphs in the lower portion of the screen” option forces the 2D graphs for 
tables such as the Warm-up enrichments over the dashboard (Figure 9).  While it covers the dashboard, 
it does prevent the window from covering any of the tuning options.  When unchecked, the graph is in a 
free floating window (Figure 10).  This is useful for large monitors because the graphs can be placed off 
to the side where they will not cover any tuning boxes. 

Figure 9: 2-D Graph Docked Figure 10: 2-D Graph Undocked 

 
Selecting Datalog Graphs 
The datalog graph tab allows the selection of up to 10 channels to view in the flight recorder.  These 
settings are covered in the Flight Recorder section. 
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Fundamentals 
Save Often 
There are a few good habits to implement when doing anything on a computer.  These are especially 
good habits when tuning a car.  A computer crash in the middle of your work can be very frustrating.  
You’ve been working for two hours, finally feel like you’re getting somewhere, when the computer 
stops responding.  We’ve all had this happen at some time or another.  The best, and in fact the only way 
to prevent loss of your work before a crash occurs is to save often.  Really, you can’t save too often.  
Ctrl + S (the quick key to save your file) should be your best friend.  After you make a few changes, 
save the file by either clicking the save button or pressing Ctrl + S.  This minimizes the chances of 
losing work on the computer in any application. 
 
Choose a new name at milestones 
Another good habit to have is to save the file with a new name 
when you reach a milestone.  For example, you have gotten your 
car to the point where wide-open throttle is right, but you still have 
drivability issues to work out.  Before you begin making changes, 
save the file with a new name by clicking “File->Save As” and 
typing in a new name (Figure 11). This gives you the option of 
going back to a known point in the tune if you don’t like the result 
of the changes or something else goes wrong.  Additionally this 
gives you multiple copies of your program in the event something 
happens to one of the copies. Figure 11: File -> Save As
 
Know where your file is saved 
Another thing that can happen occasionally is you save your file, but don’t know 
where it is.  When you wish to retrieve your BIN file, the file should be stored where 
it may be easily found.  The best way to avoid this problem is to designate a specific 
place where you ALWAYS save your files.  A great choice is the “My 
Documents” directory that appears on virtually every Windows desktop (Figure 
12).  Open the directory from your desktop and create a directory in there that 
will hold your BIN files.  To do this, click File->New->Folder in the 
My Documents window, and call the new directory: BINS (Figure 
13). When you save your file in WinTEC, save it to this location 
(Figure 14).  After doing 
this once, WinTEC will 
default to your designated 
directory every time, but 
you should still check to 
be sure of where your 
files are going.  

Figure 12: My 
Documents Folder

 
 
 
  Figure 14: → Save in My 
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Figure 13:  File → New → Folder

 Documents\ BINS 
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Tips on Naming files 
The name of the file is very important.  It should tell you something about that file.  This is even more 
important when you deal with many BIN files or multiple applications in different vehicles because 
there may be a lot of information that must be conveyed.  The unit will store up to 24 characters, which 
should allow for plenty of description.  Don’t forget that the names must be helpful to you, but not 
necessarily to anyone else.  So if you deal with only your own car, “turbo initial tune” is probably 
enough.  If you change your cam, “turbo new cam” will work.  Adding the date is only useful if it will 
have meaning for you.  Someone who tunes many vehicles needs to be more careful.  The last name of 
the owner should probably be in the file name.  The date might be useful here so it can be matched up 
with a dyno sheet or even a bill. 
 
Backups 
Backups are very important.  If your computer is stolen or breaks down you need to have another copy 
of your BIN file somewhere separate so that you still have your data.  In the long run, the data is what 
makes the computer valuable.  Therefore, having a backup is essential. 
 
How often you need to backup is somewhat dependant on how often your data changes.  When working 
with a lot of files everyday, a backup every week is fine, but a backup every day would be better.  If you 
work with WinTEC only sporadically, backing up the data after you use it is a good idea.  Simply 
copying your data to another disk or CD is all that is needed.  Do not keep your backups in your laptop 
bag.  Keep them in a desk or a safe somewhere separate.  This way if your laptop and bag are stolen, you 
don’t lose your backups with it. 
 
What you use to backup your data is also important.  Floppy disks are inexpensive, widely available and 
often large enough to hold the data you need to backup, but tend to be very unreliable.  Any magnetic 
field near by can cause data corruption.  They also have a limited shelf life.  CD’s are much more 
reliable, and hold far more data allowing you to backup more data at once.  They also cannot be 
accidentally erased. 

Version 1.1a Page 7  Electromotive, Inc. 2006 



WinTEC v4 Software User’s Guide 

Creating a New Calibration file 
Creating a new BIN file only requires filling out a form to get started.  To begin Click File -> Create a 
New BIN file.  This brings up the Create BIN wizard (Figure 15).  Follow this order for the best results: 
 
1. Select the unit type (TECGT, XDI2). 
2. Select the engine type 
3. Enter a maximum RPM.  This will 

be your default primary rev-limit. 
4. Enter the MAP sensor type.  IF you 

have an XDI2, skip to the end. 
5. Enter a Minimum Injector Turn-On 

time (MIT).  1.5 ms is a good 
starting point. 

6. Enter a TPS fully closed voltage.  
You probably won’t know this, if 
this is a new installation.  If you 
know the value, enter it here.  If not, 
enter .75v and change it in the sensor 
parameters when you have the 
monitor up and running. 

7. Select the camshaft style.  This only 
makes a minor difference in the 
estimated TOG that will be 
calculated and will not affect 
operation of the system. 

8. Enter the number of injectors. 
9. Select the injector current.  When 

running a single injector per channel, 
the 2-amp setting is the most 
common.  The 4-amp setting is 
generally used for two injectors per 
channel. 

Figure 15: Creating a BIN file 

10. Enter the estimated horsepower at the crank for your engine.  This may be just a guess, but the 
better your guess is, the closer to correct the TOG will be. 

11. Check the alcohol fuel check box if you are running methanol or ethanol. 
12. When you click the injector size box, the minimum size injector required will appear.  Your actual 

injectors should be bigger than this.  Enter the actual size in place of the minimum size. 
13. After entering the injector size and pressing enter, the suggested estimate for TOG will appear at the 

bottom of the window.  Enter this value in the TOG box. 
14. Leave IOT at 0 for now. 
 
After completing the form, click “Create BIN file”.  This will complete the process and load the file.  
This file should be good enough to program into your unit and start the engine.  The tune will not be 
good, but, if your wiring is correct and you have no other problems the car should start and run well 
enough to get the car to a tuner or to begin tuning yourself. 
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Opening an existing file 
If you already have a file you want to work with, click the Open button in 
the upper left of the screen (Figure 16), or press Ctrl + O.  If the file has 
not been opened in your copy of WinTEC before, you will be asked for 
the system type (TECGT or XDI2).   
 
If you have a file open already, you will be prompted to save the file 
before opening the new file. Figure 16: Open a file 

Loading a Calibration into the unit 
Once you have the BIN file you are going to use established, you 
must program your TECGT or XDI2 before starting your engine 
for the first time.  With the BIN file open and the unit connected 
to the PC and powered on, click the Program button at the top of 
the screen (Figure 17).  The unit will begin to program.  You will 
be instructed to cycle the power on the unit once the process is 
complete.  Pressing Ctrl + T will have the same effect as clicking 
the Program button. 

Figure 17: Program Button 

 
If a program operation fails, first make sure that your engine is off.  Attempts to program a BIN file with 
the engine running will immediately fail.  If the engine is not running, check you connections and ensure 
that the unit is communicating with WinTEC. 

Editing a Calibration file 
Monitoring 
WinTEC does not automatically begin showing data from the connected system.  Clicking the Monitor 
button or pressing Ctrl + M will start or stop monitoring.  A BIN file must be open for monitoring to 
work.  If the unit is turned off or otherwise loses connection while monitoring, a “No Connect” message 
will appear in the lower right of the dashboard.  The “No Connect” message will disappear and 
monitoring will resume when the connection is re-established. 
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ONFLY tuning 
The ONFLY tuning feature allows changes to be made to the calibration while the engine is running so 
you can immediately see the effects.  Changes made ONFLY are temporary.   
With the exception of the GPIO options and the tables, all values that can be changed ONFLY will be 
highlighted with yellow.  If the boxes for the values are not yellow, and the unit is connected, 
monitoring must be enabled.  This will establish communication and enable ONFLY tuning. 
 
If you save the file with the unit connected, either by clicking “Save” or by pressing Ctrl + S, any 
ONFLY changes will be made permanent in the unit.  The engine may stumble very briefly when the 
changes are saved, this is normal and will not cause any damage.  If the unit is turned off without saving 
the changes to the PC, the unit will restart with your old settings.  You will need to program the unit to 
apply the new settings and make them permanent. 
 
Some settings cannot be changed ONFLY.  Here is the list of settings that must be changed and then 
programmed to take effect: 
 
Engine type 
TDC tooth 
Injector Peak current 
GPIO function 
Idle speed control valve type (2-wire, 4-wire) 
Any setting to enable/disable a subsystem or sensor (i.e. Idle Control On/Off, MAT Enable/Disable, etc) 
Turn IAC off at Minimum duty 

Editing a Table 
Changing a single cell in the table is very simple.  Click on the cell you wish to edit or use the arrow 
keys to move to the cell you wish to change, type the new value and press enter.  The value may also be 
incremented up or down by using the “<” key for a decrement and the “>” key for an increment. 
 
Clicking and dragging over several cells or 
holding the shift key while moving the 
cursor with the arrow keys will select 
multiple cells (Figure 18).  Once the cells 
are selected, typing a new value will fill all 
of the cells with that value.  Multiple cells 
can be incremented or decremented with the 
“<” and “>” keys as well.  The cells may be 
incremented as many times as you like, but 
you will be warned if any of the values hit a 
limit (i.e. 60 degrees is maximum in the 
ignition table). Figure 18: Selecting multiple cells in the table 
 
The row and column MAP and RPM points 
can be changed from any table (VE, Ignition, GPIO full table, etc).  Double clicking an RPM or MAP 
value will show a dialog box that asks for a new value.  Remember that any change you make affects all 
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tables.  Clicking the Setup button brings up a screen allowing changes to all of the RPM and MAP 
values at once. 
 
When a unit is being monitored, a small red dot will float over the table in the location the unit is 
operating.  This simply shows you where the engine is operating to allow tuning to the appropriate part 
of the map.   
 
When attempting to tune a set of cells, it may be helpful 
to see all of the cells touched by the unit.  This can be 
done by enabling color persist.  In the software, this is 
called overlay.  This can be enabled and disabled by 
pressing Shift + O or clicking the down arrow next to 
Setup and selecting overlay ON or overlay OFF.  Overlay 
is turned off when changes are being made and must be 
re-enabled after the changes have been made either with 
the menu or by pressing Shift + O.  The color persist will 
carry over to other tables when switching.  Clicking the 
options menu and selecting ‘Reset to White’ will clear 
the persist marks. Figure 19: Table Options Menu 
 
There is an option in the options menu called AFR colors.  This makes the overlay change color with the 
AFR needle in the dashboard.  This option combined with persist makes it very easy to see where the 
mixture is lean or rich while tuning.  Normal Colors switches to the default yellow.  AFR colors can be 
set as the default in the Control Panel (See the section on 
Changing the Dashboard Appearance). 
 
You can view a 3-D graph of each table by clicking on 
the Tools menu (Figure 20) and selecting Graph.  One 
point on the graph is highlighted and the information for 
that point is displayed in the upper left of the graph 
window. 
 
Sometimes it is useful to see what the effective pulse 
width for each cell in the VE table will be.  To do this, 
click on the tools menu and select Show Injector Pulse 
width Table.  This option is only available in the VE 
table.  When viewing the pulse width table, any cells with a pulse less than the minimum turn on time 
will be highlighted in red.  Seeing the duty cycle in the VE table can also be quite useful.  Click the tools 
menu and select Show Injector Dutycycle.  Any cell with greater than 100% duty cycle will be 
highlighted in red.  To return to the VE table, click the “Home” button (visible in Figure 19). 

Figure 20: Table Tools Menu 

 

Editing the General Purpose Input/Outputs (GPIOs) 
The GPIOs are very flexible and have a lot of options.  To ease their configuration, the channels are 
shown numbered then each channel will only show the functions available to that channel. 

Version 1.1a Page 11  Electromotive, Inc. 2006 



WinTEC v4 Software User’s Guide 

 
To configure a GPIO, click on the General 
Purpose Input/Output option in the Navigation 
tree.  In the configuration screen that appears, 
there is a drop down for selecting a GPIO channel 
(Figure 21). Some channels, will have an “Input” 
or “output” next to the number.  This means that 
channel only has input or output functions 
available to it. 
 
After you select the channel you want, the list of 
available functions will be shown in the box 
below the channel drop down.  To select a 
function click the check box next to the function 
you want (Figure 22).  The unit must be disconnect
change the function. 
 
Once you have selected a function, the 
configuration options will appear to the 
right.  Double click the option you want to 
change.  A dialog box asking for the new 
value and showing the acceptable range will 
appear (Figure 23). Enter the new value 
here.  Changes made here may be done 
ONFLY and will take immediate effect 
when the unit is connected and powered on. 
 
 
 

Configuring the EGO (TECGT only) 
The TECGT supports both narrow band and wideband
sensors.  The correct type must be selected before it w
operate correctly.  Click either Narrow Band or 
Wideband in the EGO Calibration screen to make the
selection (Figure 24).  Narrow band is the default. 
 
Narrow band sensors virtually all work the same way
Therefore, the default calibration for the narrow band
sensor should be fine.  Wideband sensors will each li
have a different calibration.  This information can 
typically be found in the documentation included wit
sensor, or can be obtained from the manufacturer.  Th
in the middle of the screen (Figure 25).  The voltages
from highest to lowest may be necessary.  If the sens
readings will most likely be incorrect. 
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Figure 25: 
Calibration 
table for the 
EGO sensor 

The two numbers at the bottom are failure voltages (Figure 26).  If the EGO voltage is outside these two 
voltages for the amount of time defined in the EGO sensor parameters, a failure code will be triggered. 
 

Figure 26: EGO 
failure voltage settings  
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Flight Recorder 
The flight recorder in WinTEC v4 is meant to give the user a simple tool to watch what the vehicle is 
doing.  The flight recorder works like a VCR.  The data you have recorded on the dashboard will 
playback in real time and show the data in graph form. 
 

 
Figure 27: The Flight recorder. 

Recording 
To start a new datalog, click the record button and enter a name for the session.  The name of the session 
defaults to Session_<date>, where <date> is today’s date.  Names can be long and include spaces.  
When the recording is complete, click the stop button.  The datalog will then be loaded and ready for 
analysis. 

Playback 
If you did not just record a session, you will need to load a 
datalog before doing any play back.  Select a session from 
the ‘sessions’ pull down (directly above the timer).  If the 
datalog you want to view is not listed, you will need to 
import the data log.  See the section on importing another 
user’s datalog. 
 
The data will always play back on the dashboard in real time 
when playing a datalog, but the graphs help show trends and 
find anomalies.  If you have not already done so, you will 
need to select what data will be displayed in the small graphs 
on the right.  The graphs that will be displayed in the space at 
the right are selected in the Control Panel from the Datalog 
Graphs tab (Figure 28).  These options can also be reached 
by clicking the “Graphs” button at the upper right of the 

Figure 28: Datalog Graph selection 
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small datalog graphs.  You can select up to 10 channels for display.  The number or channels you have 
selected is the small blue number in the lower right of the select screen.  These graphs can be changed at 
any time, including during datalog playback. 
 
Control of the flight recorder works much like a VCR or DVD player.  Here is a brief description of 
what each control button does: 
 
First: Jump to the beginning of the file 
Rew: Step one record back (pauses playback if playing) 
Rev: Plays the file at the selected speed in reverse 
Stop: Halts playback.  Playback will resume from the current position.  If already stopped, timers and 
position is reset to the beginning. 
Play: Plays the file normally at the selected speed 
Fwd: Step one record forward (pauses playback if playing) 
Last: Jump to the end of the file 
Record: Begin recording a new file 
 
The playback speed can also be changed to quickly get to a specific point or to see a portion in more 
detail.  The playback speed slider above the control buttons changes the playback speed.  The Slowest 
setting is about ¼ speed and the fastest is about 4x normal speed. 

Importing another user’s datalog 
If another WinTEC user has a datalog they made in WinTEC, their file can be imported into your 
datalog list using the “Import” button.  After selecting the file, it is read in the same way as selecting a 
datalog from the drop down.  The file is also added to the drop down.  You may then use the datalog as 
though you had recorded it yourself.  Only datalog files made with WinTEC4 are supported. 
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Firmware Upgrade 
The firmware versions used with WinTEC v4 are handled a little bit differently from the past.  WinTEC 
v4 is written to work with many different systems and firmware versions.  Differences between units 
and firmware versions are all handled automatically.  What this means is that as long as you have the 
newest version of WinTEC v4, you will always be able to communicate with any unit supported by 
WinTEC v4.  Firmware version no longer prevents the ability to communicate or program any supported 
unit. 
 
The firmware version does, however, dictate what features the unit supports.  Having the newest 
firmware for your Electromotive system ensures that you will have access to all the features available. 
 
That said, a firmware upgrade should not be taken lightly.  If your vehicle is operating properly and you 
are satisfied with the features you have, a firmware upgrade should not be performed.  If it is not broken, 
do not fix it. 
 
Doing a firmware upgrade is fairly simple but does require a number of steps.  If you’ve read to this 
point, and still want or need to upgrade, here are the steps: 
 

1. Start WinTEC and connect your system.  Allow WinTEC to find the unit. 
2. Open you BIN file. 
3. Power the unit down and disconnect the serial cable from the unit 
4. Using a small Allen wrench or flat head screwdriver (no bigger than 7/64” or 2.5 mm), press the 

button behind the small hole next to the serial port. 
5. With this button held down, power on the unit.  This should not take much effort, do NOT press 

too hard.  You should feel the button give when pressed. 
6. The LEDs should indicate that the unit is in boot loader mode.  The TECGT should show red on 

top and green on the bottom.  XDI2 will show green on top and red on the bottom.  If the LEDs 
do not show what you expect, repeat steps 2 and 3 until the sequence is correct. 

7. Once the unit is in boot loader mode, reconnect the serial cable. 
8.  Click on Tools -> Options -> Firmware upgrade. 
9. Click OK on the warning dialog that pops up. 
10. Specify the firmware upgrade file.  It will end in “.EM3”.  A file starting in “WTL” is for a 

TECGT and one beginning in “WXD” is for an XDI2. 
11. Once selected, the process will begin.  Be sure not to disconnect the serial cable or turn the 

unit or the PC off during this process. 
12. When the process completes, turn the unit off, then back on.  This completes the process.  The 

BIN file already on the unit is kept intact. 
 
If for some reason the process fails, the top LED will be OFF when the unit powers back on.  Whether 
caused by a bad file, from the laptop losing power, the shop dog stepping on the serial cable or 
something else.  All is not lost.  Fix whatever may have caused the problem and start the process again 
from the step 3. 
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Appendix: Shortcut keys 
Navigation 
F5 – Ignition table 
F6 – VE Table 
F7 – Staged Injection Table 
F8 – AFR Table 
Tab – jumps to the next box or from the tree to the first box of the selected screen 
Arrow Keys – Move around the navigation tree 

File Control 
Ctrl + N – Create a new file 
Ctrl + O – Open a file 
Ctrl + S – Save the current changes, make ONFLY changes permanent in the unit 

TEC Control 
Ctrl + T – Program current BIN file into connected unit 
Ctrl + M – Start/Stop Monitoring 

Table Control 
Shift + O – Enable/Disable Overlay (color persist), Monitor mode only 
Shift + X – Close table and return to navigation tree 
Arrow Keys – move to another cell 
“<” – Decrement the selected cells by one 
“>” – Increment the selected cells by one 
Shift + Arrow Key – Select multiple cells 
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Glossary 
 
Advance: As applied to ignition timing, advancing the timing refers to firing the spark plug 
comparatively sooner. 
 
Boost: When a pressure that is greater than the ambient atmospheric pressure is forced into the intake 
manifold. Turbo- and superchargers create boost. 
 
Cam Sensor: A device used to provide a once-per-engine cycle pulse to the TEC. This establishes the 
stage of engine operation that is occurring for a given TDC. 
 
Closed Loop: When an oxygen sensor reading is used to correct the air-fuel mixture through the 
manipulation of the fuel injector pulse widths. 
 
Coolant Enrichment: A coolant temperature-based fuel enrichment that is used to add fuel when an 
engine is cold. This feature is the electrical equivalent of the choke plate on a carburetor. 
 
Coolant Temperature Sensor: A device that measures the coolant temperature of an engine. 
 
Crank Sensor: A device that can “read” a crank trigger wheel, and output a voltage signal that can be 
used by an engine management system. 
 
Crank Trigger: A device used to measure the crankshaft position and speed, typically composed of a 
crank trigger wheel and a crank sensor. 
 
Detonation: When the air-fuel mixture is ignited by the spark plug, then a high cylinder temperature 
“spontaneously” ignites another portion of the unburned mixture. A knocking sound is produced when 
detonation occurs, and knock sensors are designed to hear this knocking. Engine damage can be caused 
by detonation. 
 
DFU: Direct Fire Unit. Electromotive coil packs are referred to as DFUs. 
 
Directory: A subsection of disk space on a computer.  May be within another directory.  Typically used 
for organization.  Also called a Folder. 
 
Duty Cycle: The percentage of time that a pulse width modulated output is turned on. A duty cycle of 
100% indicates a fully turned-on modulation output. 
 
ECU: Electronic Control Unit. A device that is used to process several inputs for the control of several 
outputs. 
 
Exhaust Gas Oxygen (EGO) Sensor: A device that compares the oxygen content of the exhaust gases 
with the oxygen content of the ambient atmosphere. An air-fuel ratio approximation can be made with 
an EGO sensor. 
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Enrichment: A software parameter that adds injector pulse width (typically as a percentage) to the 
values defined by the raw fuel curve. 
 
Folder: See Directory. 
 
Fuel Pressure Regulator: A device that regulates the fuel rail (and thus the fuel injector) pressure. 
Generally equipped with a vacuum port referenced to manifold vacuum/boost to adjust fuel pressure on 
a 1-to-1 basis with manifold pressure. For examples, a regulator will increase fuel pressure by 1psi for 
every psi increase in manifold pressure. 
 
Gamma: See TFPW. This number is no longer used with TEC3 systems. 
 
General Purpose Inputs (GPI): Input channels that the TEC3 can use to process data from sensors that 
are not related to the core engine management sensors. Switches and vehicle speed sensors can be run to 
the GPIs. 
 
General Purpose Outputs (GPO): Output channels from the TEC3 that can be used to trigger external 
devices such as thermofans, torque converters, etc. 
 
Horsepower (HP): A measurement of the rate at which an engine can perform work. 
One HP = 550 lb-ft per second. 
 
Idle Air Control (IAC) Motor: A device that is used to meter air into an engine at idle. 
Air from the outside of the intake manifold is regulated into the intake plenum by the 
IAC motor. 
 
Ignition Timing: The amount of degrees before Top Dead Center that a spark plug fires. 
 
IOT: Injector Offset Time. This number adds or subtracts a fixed pulse width from the raw fuel curve. 
The value of IOT is the amount of time (in milliseconds) that will be added or subtracted to the final 
pulse width. 
 
Knock Sensor: A device used to measure detonation. 
 
Knocking: see ‘Detonation’ 
 
Lean Mixture: An air-fuel mixture that carries less fuel than the stoichiometric air-fuel ratio. 
 
Manifold Air Pressure (MAP) Sensor: A device that measures the absolute pressure of the intake 
charge for an engine. 
 
Manifold Air Temperature Enrichment: An inlet air temperature-based enrichment that is used to add 
fuel when the incoming air is cold, and therefore denser than usual. 
 
Manifold Air Temperature (MAT) Sensor: A device that measures the temperature of the incoming 
air charge for an engine. 
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Millisecond (ms): A length of time equal to one one-thousandth of a second.  1 millisecond = 0.001 
second 
 
Mixture: A term used to describe the air and fuel entering the engine as a single entity. 
Open Loop: When an engine is running off of its base calibration with no EGO sensor feedback to 
correct the air-fuel ratio. 
 
Pinging: See ‘Detonation’. 
 
POT: Pulse Width Offset Time (now Injector Offset Time). This number is not used with WinTEC v4 

systems, but was used in WinTEC 3. ‘See IOT.’ 
 
Pre-Ignition: When the air-fuel mixture is ignited by a hot spot in the combustion chamber BEFORE 
the spark plug fires. When pre-ignition occurs, it produces a similar effect to advancing the ignition 
timing too much. Engine damage may result. 
 
Pulse Width: The amount time that an injector is turned on for a given operating scenario. Expressed in 
milliseconds (ms). 
 
Pulse Width Modulation (PWM): When a variable pulsed voltage signal is supplied to a module, pulse 
width modulation is occurring. Fuel injectors are common examples of 
PWM-controlled modules. 
 
Stoichiometric Mixture: An air-fuel mixture that has the chemically ideal ratio between incoming air 
and fuel. When combusted, the product of a stoichiometric mixture will carry no excess air or fuel. 
 
Retard: As applied to ignition timing, retarding the timing refers to firing the spark plug comparatively 
later. 
 
Rich Mixture: An air-fuel mixture that carries more fuel than the stoichiometric air-fuel ratio. 
 
Rising Rate Fuel Pressure Regulator: A Fuel Pressure Regulator that is adjustable to provide a non 1-
to-1 relationship between manifold pressure and fuel pressure. For example, a rising rate regulator may 
be used to supply 2psi of fuel pressure increase with every 1psi of manifold boost. 
 
Spark Knock: See ‘Detonation’ 
 
TFPW: Total Fuel Injector Pulse Width. This number defines that total modification to the raw fuel 
curve that is occurring at a given instant. A TFPW of 100% indicates that no modification is occurring 
to the raw fuel curve. A TFPW less than 100% indicates a leaner pulse width than the raw fuel curve 
value, while a TFPW greater than 100% indicates a mixture that is richer than the raw fuel curve value. 
 
Throttle Position Sensor (TPS): A device used to measure the position of the throttle. 
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TOG: Time for One Gama. This number defines the slope of the raw fuel curve. When POT is zero, the 
raw fuel curve will have zero pulse width at zero MAP sensor volts.  When the MAP sensor is at 
+5volts, the pulse width will be the number entered into TOG, expressed in milliseconds. 
 
Torque (TQ): A measurement of the work that an engine can perform, typically expressed in pound-
feet (lb-ft). 
 
TPS/MAP Blend: A feature of the Wintec software that allows the TPS and MAP sensor readings to be 
blended together. Typically, this feature is used on engines with radical cams or throttle-per-cylinder 
setups since these engines have poor MAP signals at idle and part throttle. 
 
Trigger Wheel: A device attached to the crankshaft that provides a moving reference of speed and 
position of an engine’s crankshaft. 
 
UAP: User Adjustable Pulse Width (now TOG). This number is not used with WinTEC v4 systems, but 
was used in WinTEC3. See ‘TOG.’ 
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